Problem with dealii adapter: unable to find the executable elasticity

Dear community, I recently installed the PreCISE adapters for FSI simulation and was able to run the simulation using OpenFOAM and calculix. However, when I am trying to run the fsi related to the DEALII adapter it’s not working. when I run the fsi it shows “unable to find executable elasticity”. I came across a user’s post for the same and I tried to do the same but nothing seems to work. I have attached the screenshot for the same.

I would be glad if anyone can help me with the problem.

You export /home/daniel/deal-adapter/, but the directory is actually called /home/daniel/dealii-adapter/ (see the extra ii). Could this be the error? If not, could you show the content of /home/daniel/dealii-adapter/? Is there a file called elasticity?

A great way to avoid such typos: use that Tab key to auto-complete paths. It is a life-saver!

Sorry, I made a mistake, but it’s still not working!

There is a file named elasticity.

Below I have attached the screenshot of both

Hi @daniel,

according to your explorer, there is just cc file called elasticity. You need to generate the executable before you can run the tutorial. Checkout our installation instructions: Get the deal.II adapter | preCICE - The Coupling Library

Yeah, just as @DavidSCN is saying, there is a file called You need to tell Windows to show file endings to actually see it . If you change into the directory using you Ubuntu terminal and check files via

cd /home/daniel/dealii-adapter/
ls -l

you should see the file ending. You need to follow the steps suggested by @DavidSCN to create the actual executable which will have no file ending.

I checked the instructions but I am finding it difficult to generate the executable. I tried both the commands but it’s not working.
cmake .

cmake -DDEAL_II_DIR=/path/to/deal.II -DpreCICE_DIR=/path/to/precice .

You need to navigate into the adapter directory before executing cmake, this step is indeed missing in the description (will fix that).
First go into the directory:

cd /home/daniel/dealii-adapter

and continue afterwards with cmake as described on the website.

Dear David, I was able to do what you told me. But I doubt whether the elasticity file is still executable.

This looks good. Maybe the third step in the set of building instructions on the website is not obvious enough, but if you execute now make in the directory you are in, everything should work like a charm.

The elasticity file is still not executable !

Let me double check again: I guess we require deal.II version 9.2 and we currently do not enforce this (you have probably v9.1), let me fix it.

If you downloaded the adapter via git, you can use git pull to see the actual version requirement. How did you install deal.II and which version do you use?

Hello David, you were right I had deal.II version 9.1. I uninstalled it and I downloaded the version dealii-9.3.1. from the official website. Following the steps from the official website it says

mkdir build
  cd build
  cmake -DCMAKE_INSTALL_PREFIX=/path/to/install/dir ../deal.II

I did the above two steps, but when I try to do the third step its not working. The error is pictured below, even though there is a directory named deal.II

I think you are missing someting at the end of your cmake command. It does not look like you are specifying the directory containing deal.ii.

Maybe you have to call something like

cmake -DCMAKE_INSTALL_PREFIX=/home/daniel/dealii-9.3.1/include/deal.II ..


cmake -DCMAKE_INSTALL_PREFIX=/home/daniel/dealii-9.3.1/include/deal.II /home/daniel/dealii-9.3.1/

I must also admit that your installation prefix seems a bit odd to me. Do you really want to install deal.ii in the directory /home/daniel/dealii-9.3.1/include/deal.II?

Guessing that you are using Ubuntu, let me start by saying that there are also more recent versions available through your package manager: you could just install the package libdeal.ii-dev, which should be recent enough.
Other than that consider the comment from @ajaust : the dots .. tell cmake where to find the sources. You could skip the install prefix for the moment and just run

mkdir build && cd build && cmake .. && make -j 4`

In case this command succeeds, the library would already be comopiled with default configurations. Afterwards, you could just export your DEAL_II_DIR globally as DEAL_II_DIR="$HOME/dealii-9.3.1/build".

Thanks @DavidSCN @ajaust I was able to solve the problem. As you told the installation directory was odd I created new directory outside. Unfortunately I ran out of space. Any tips if I can install everything on other drive.

Do you virtually run out of memory or physically? Do you have an option to increase the limits of your VM? Of course you can build everything on an external drive and run make install in order to copy the relevant sources into your system, but I have not tried something similar. I would rather recommend to free up some space.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.