Problem running flap_perp tutorial example

Hello, I tried to run this example recently, using OpenFoam v2012-Calculix 2.16, and encounters an error:

“The interpolation matrix of the RBF mapping from mesh Fluid-Mesh-Faces to mesh Solid is not invertable. This means that the mapping problem is not well-posed. Please check if your coupling meshes are correct. Maybe you need to fix axis-aligned mapping setups by marking perpendicular axes as dead?”

In fact, it run successfully one week ago, but after some system update I recompiled all the packages and see this error. I’m struggling of the reason.

I run using the same data on the tutorial. Nothing changes. In the config I saw "y-dead=“true”. Change to x-dead or z-dead gives the same error.

Following the suggestion in another thread, I change to use nearest neighbour mapping:

<mapping:nearest-neighbor direction=“write” from=“Fluid-Mesh-Faces” to=“Solid” constraint=“conservative” timing=“initial” />
<mapping:nearest-projection direction=“read” from=“Solid” to=“Fluid-Mesh-Nodes” constraint=“consistent” timing=“initial” />

But OpenFoam does not converge at the second step (show nan values).

For sake of comparison, the original mapping is:

<mapping:rbf-thin-plate-splines direction=“write” from=“Fluid-Mesh-Faces” to=“Solid” constraint=“conservative” y-dead=“true” />
<mapping:nearest-projection direction=“read” from=“Solid” to=“Fluid-Mesh-Nodes” constraint=“consistent” timing=“initial” />

Hi @vryy,

which branches of your individual repositories are you using for your setup? If you use the develop branch of the tutorials, make sure you use the (non-default) develop branch of the adapters as well. If you use the master branch, you probably need to remove all the dead axis (IIRC there is an erroneous config somewhere) in the tutorial or just wait for another week, when the master branch will be updated.


Thank you, I could run this example using the develop branch for both tutorial and adapter.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.