Installing the OpenFOAM adapter: mixed OpenFOAM versions

I have installed openFOAM 8 but the adaptor installation when i run ./Allwmake, its giving me the following error.

Building the OpenFOAM adapter for preCICE...

Current OpenFOAM environment:

The adapter will be built into:
  ADAPTER_TARGET_DIR    = /home/lkadzungura/OpenFOAM/lkadzungura-8/platforms/linux64GccDPInt32Opt/lib

The following building options will be used:

Dependencies (preCICE) will be located using the following environment variables:
      preCICE dependencies: not specified (ok if preCICE is built as a shared library)
  ADAPTER_PKG_CONFIG_LIBS         = -lprecice
  ADAPTER_GLOBAL_LD_LIBRARY_PATHS = -L/opt/ThirdParty-8/platforms/linux64Gcc/gperftools-svn/lib -L/opt/openfoam8/platforms/linux64GccDPInt32Opt/lib/paraview-5.6 -L/opt/paraviewopenfoam56/lib -L/opt/openfoam8/platforms/linux64GccDPInt32Opt/lib/openmpi-system -L/opt/ThirdParty-8/platforms/linux64GccDPInt32/lib/openmpi-system -L/usr/lib/x86_64-linux-gnu/openmpi/lib -L/home/lkadzungura/OpenFOAM/lkadzungura-8/platforms/linux64GccDPInt32Opt/lib -L/opt/site/8/platforms/linux64GccDPInt32Opt/lib -L/opt/openfoam8/platforms/linux64GccDPInt32Opt/lib -L/opt/ThirdParty-8/platforms/linux64GccDPInt32/lib -L/opt/openfoam8/platforms/linux64GccDPInt32Opt/lib/dummy 

Building with WMake (see the wmake.log log file)...

=== ERROR: Building failed. See wmake.log for more. ===
Possible causes:
- Make sure you are using a compatible version of the adapter for your OpenFOAM version:
- Is preCICE discoverable at compile time? Check the content of ADAPTER_PKG_CONFIG_CFLAGS above.

I am new to preCICE. The Allwmake.log file is also giving me the same information as that which is showing on the terminal. i tried the solution for an earlier post, where i had to remove a certain line from the options file but i didnt work. I also tried installing the version of openfoam which is openfoam2012, when i run the ./Allwmake, it still links with OF8, please help. i am stuck

At the moment, we don’t only experimentally support OpenFOAM 8. Our main branch supports the latest ESI version by default. Read more details.

Could you please upload your wmake.log file?

Edit: Some of you may have received this via email because the thread was originally submitted to the News category, which I did not notice. That was only a mistake.

Hie MakishH

I solved the problem, i ended up changing the location of openfoam2012 which i installed and put it in /opt directory and set the source path in the .bashrc file changed from openfoam8 to openfoam2012 because when i initially set it to the initial path, it affected the terminal and it stopped working. Anyway after that, it worked and i managed to install the adaptor. Now i am trying to configure the adaptor. if i face any challenge i will post. I also need to get or create a Palabos adaptor, how can i get help on that.

1 Like

Great to hear that! I am renaming and closing this then, please open a new thread for each new topic.

For the Palabos coupling topic let’s continue in the thread you started a while back. I marked it again as unanswered, so we should now not miss the updates.

its okey, thank you. you can close it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.