Calculix Intel Pardiso Crash with Elastic Tube 3D Tutorial

Dear All,

I have compiled Calculix with Intel Pardiso and am using preCICE 2.3. When running the elastic-tube-3d tutorial out of the box, I get the error below. Has anyone else encountered a similar issue? Any thoughts on what may be causing the issue?

Many thanks,

Setting up preCICE participant Calculix, using config file: config.yml
---[precice]  This is preCICE version 2.3.0
---[precice]  Revision info: v2.3.0
---[precice]  Configuration: Release (Debug and Trace log unavailable)
---[precice]  Configuring preCICE with configuration "../precice-config.xml"
---[precice]  I am participant "Calculix"
Set ID Found 
Set ID Found 
Setting node connectivity for nearest projection mapping: 
ERROR: Cannot apply forces to one or more interface nodes.
corrupted double-linked list
[LAPTOP-Kj65:01901] *** Process received signal ***
[LAPTOP-Kj65:01901] Signal: Aborted (6)
[LAPTOP-Kj65:01901] Signal code:  (-6)


I ran the tutorial successfully on my own laptop (with Linux Mint) so the problem shouldn’t be in the configuration of the tutorial.
What version of Calculix & the adapter are you running ? (Are you sure there isn’t a mismatch between Calculix version and adapter version ?)

Are you able to run other tutorials ? (e.g. partitioned beam)

It seems the error is thrown from the function “getXforcIndices” but I’m not skilled enough to dig further.

I never built with Pardiso though, maybe try building with SPOOLES instead ?
I don’t see how changing the solver could impact the adapter’s configuration process, but life is full of surprises.

Best of luck !

Hello @boris-martin,

Many thanks for the reply. My problem turned out to be the use of the FLAG i8 as well as the use of the Intel Compiler to build ccx_preCICE. Once I switched to gfortran everything went smoothly this morning. Thanks again for the reply.

Best wishes,

1 Like

Hi @JWilliams,

Glad you found it ! For reference in the future, I’m not sure I understood 100% your fix. Do you need to disable the -i8 flag, or to enable it ? or was it enough to switch compiler ?

Thanks for the feedback !

Hello @boris-martin,

I actually had to remove the -i8 flag as part of the fix along with the change in compiler. Apologies for not being clearer in my previous response.
Enjoy the weekend!

Best wishes,

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.