FSI Simulation Gives Error for solid-calculix

Hello
I was trying to run the tutorial perpendicular flap simulation on my computer. when I called ./run.sh for fluid-openfoam it worked but when I did the same for solid-calculix, it gives me the following error:

./run.sh: 4: ccx_preCICE: not found

Would appreciate y’all’s help

Did you successfully build the CalculiX adapter?

I have been trying to build the adapter but it gives me this error;

I also get a liprecice error which is addressed here but I was unable to fix.

this is what I have on my bashrc file right now:

PRECICE_PREFIX=~/precice
export LD_LIBRARY_PATH=$PRECICE_PREFIX/lib:$LD_LIBRARY_PATH
export CPATH=$PRECICE_PREFIX/include:$CPATH
# Enable detection with pkg-config and CMake
export PKG_CONFIG_PATH=$PRECICE_PREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
export CMAKE_PREFIX_PATH=$PRECICE_PREFIX:$CMAKE_PREFIX_PATH

Hi @mishal49 ,
when I encountered this error, it originated from the PRECICE_PREFIX line in the bashrc.
Try to insert the full path without the ~. Such as PRECICE_PREFIX=/home/user/.../precice
Maybe this helps you.

Hey @Luna
I did as you instructed but when I typed source it gave me the following. Do you know why?

This is what I changed it to:

PRECICE_PREFIX= /home/mishal49/precice
export LD_LIBRARY_PATH=$PRECICE_PREFIX/lib:$LD_LIBRARY_PATH
export CPATH=$PRECICE_PREFIX/include:$CPATH
# Enable detection with pkg-config and CMake
export PKG_CONFIG_PATH=$PRECICE_PREFIX/lib/pkgconfig:$PKG_CONFIG_PATH
export CMAKE_PREFIX_PATH=$PRECICE_PREFIX:$CMAKE_PREFIX_PATH
#PKG_CONFIG_PATH=/path/to/lib/pkgconfig

export PATH=/usr/local/CalculiX/calculix-adapter-master/bin/:${PATH}

I think you just need to remove the space before the path! Try:

PRECICE_PREFIX=/home/mishal49/precice

Hope this helps!

Oh, and when looking into my .bashrc file, I found another thing that you could try if there are more errors.
I changed the …/lib paths to …/lib64, see below. You could check in your PRECICE-PREFIX path to see whether you have a lib or lib64 directory there.

PRECICE_PREFIX=/home/luna/precice
export LD_LIBRARY_PATH=$PRECICE_PREFIX/lib64:$LD_LIBRARY_PATH
export CPATH=$PRECICE_PREFIX/include:$CPATH
#Enable detection with pkg-config and CMake
export PKG_CONFIG_PATH=$PRECICE_PREFIX/lib64/pkgconfig:$PKG_CONFIG_PATH
export CMAKE_PREFIX_PATH=$PRECICE_PREFIX:$CMAKE_PREFIX_PATH

1 Like