Problem with CalculiX-adapter when applying gravity forces

Hi everyone,

I faced a problem when applying gravity forces in FSI simulations. The gravity forces were applied on the surface of structure using CalculiX-adapter, as follows:


However, once adding the above flag in solid input file (owc.inp), the following error occurred:

Starting FSI analysis via preCICE using the geometrically non-linear CalculiX solver...
 Using up to 1 cpu(s) for the stress calculation.
 Using up to 1 cpu(s) for the energy calculation.
 Using up to 1 cpu(s) for the symmetric stiffness/mass contributions.
Segmentation fault (core dumped)

I have tried using ccx_2.19 to separately calculate the structure part, the calculation was completed with no errors. Thus, I guess the error may be related to the Calculix-adapter

Does anyone have ideas about it? Many thanks in advance!

I’m not familiar with that bug, but I can investigate it; could you also upload your mesh file and interface (.nam) files (ad well as an OpenFOAM case?) so that the full case is reproducible ?

Hi @boris-martin

Sorry for my late responses. The integrate FSI case can be find here. Many thanks in advance!!

Hi @boris-martin

By the way, I’ve tested this case using Calculix-2.15 adapter, it worked well.

I managed to reproduce the issue and it’s really weird.
Apparently there is a segfault at line 196 of “mafillsm.f” in the CalculiX code. I have no idea yet about why or how as it’s hard to debug; I’ll try to investigate further.
I don’t have a lot of free time in the coming days, so it might take some time.

If you see a segfault from the CalculiX code, it would be worthwhile to asking it in the CalculiX Discourse: