OpenFOAM-v7 adapter installtion problems

Dear preCICE community,

i searched the forums for similar problems but could not find any solution to my problem. Iam using Ubuntu 22.04 and did install the newest preCICE version 2.5.0 from source. Everything worked fine (all the tests succeeded) and i tried installing the openfoam-adapter 1.2.0 for OpenFOAM-v7 (also installed from source) and ran into installation problems (see attached log files).

Allwmake.log (949 Bytes)
wmake.log (21.6 KB)

I think one problem might be the empty output of --[precice] pkg-config --cflags libprecice. Or does that simply mean the path is already known by the system? I did add all the precice installations paths to my bashrc. Iam probably missing something trivial and any held is appreciated.

Best regards


The compilation fails before trying to link to preCICE. Is this trying to build the OpenFOAM7 branch / archive?

Thank you for your fast reply. Iam not exactly sure what you mean by this? Iam almost certain that this builds the OpenFOAMv7 branch master. Is there anyway to check?

Ahh I see. I used the wrong adapter. It is working fine now. Sorry for the stupid mistake and thank you for your help!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.