Running FSI simulations on a Server


After running a lot of simple FSI test cases on my pc, I have to run a very large simulation on a server.
I’ve already installed the two solvers (SU2 and MBDyn) along with preCICE, the adapters and the necessary dependencies. I tested SU2 and MBDyn separately and both work properly, but when I couple them I got a very cryptic error. In order to understand if the error is on MBDyn part or on SU2, I run a MBDyn-dummy test case and here the error is the same.
I’m attaching the error here:

slurm-859334.out (3.6 KB)

I’m not very comfortable at reading segmentation fault errors, so I do not understand what error comes first.

In order to run the case on the server, I have to use slurm, so I use 2 separate file: I run one in the Fluid folder and one in the structure folder.
Have anyone of you any experience with servers? Could it be an error related to the way in which I have to send the jobs? Do I need to run both commands from one single

I’ve got zero experience with servers, so any help would be greatly appreciated.

Thank you,


Did you test your preCICE installation (make test) after installation?

You could also test the Python bindings of preCICE using a solver dummy: python-bindings/solverdummy at develop · precice/python-bindings · GitHub

Hi @ajaust,

Yes I tested preCICE with make test and I also run the quickstart using SU2 instead of OpenFOAM as fluid. Everything works perfectly.
So I think it’s safe to conclude that the problem is either in the python-bindings or in MBDyn…

I didn’t try it, thanks for the suggestion.

I tried to run the solverdummy and it shows the exact same error:
solverdummy.out (2.4 KB)

I suspect the problem then is in the bindings… python3 -c import precice works though.

I would try reinstalling the Python bindings. If the dummy solvers still show the same error, it could be worth to install preCICE and the Python bindings with debugging flags to get better error messages and additional checks.

1 Like

I also run python3 test inside the Python bindings folder and it fails with the same error here:

test_get_mesh_vertices (test.test_bindings_module.TestBindings) ... [megamind:08890] *** Process received signal ***

Did you try to reinstall the bindings already or was this before reinstalling them?

After the reinstallation :sob:

Did you run python3 test following the instructions here, i.e., did you clean the build directory? I would also recommend cleaning the build directory before reinstalling the bindings.

By the way, which version of the bindings are you using? You can test this with python3 -c "import precice;print(precice.__version__)" if you do not remember.

Yes I followed all the instructions…


When I clean the build directory it shows this:

'build/lib' does not exist -- can't clean it
'build/bdist.linux-x86_64' does not exist -- can't clean it
'build/scripts-3.9' does not exist -- can't clean it

I don’t know if it’s normal…

Ok… That is weird. You could try to check against which libraries the bindings are linked against to see if anything is odd there using:

ldd /home/zanella/.local/lib/python3.9/site-packages/pyprecice-

But besides that I guess it would be best, if you could install preCICE using the debug options. A debug build version should should give better error messages.

1 Like

@alicezanella did you manage to solve this issue? If yes, how?

Related topic (which I just now assumed and marked as “solved”): Python-Bindings on server - #13

Hello @Makis,

Yes I managed to solve this issue. At the end, I re-installed Python with OpenSSL and then I used pip to install all the required packages. In this manner, I installed pyprecice directly with pip install.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.