FSI with CalculiX: multiple steps

Dear all,

I’m doing FSI with Calculix+Openfoam. For the CalculiX participant, I’m applying a pressure (DLOAD) as a boundary condition and I would like to ramp the pressure up to the maximum. For that, I tried to use two *STEP cards (see the .inp file below). This setup works fine with CalculiX alone, but not with preCICE.

preCICE shows an error when the first step is finished:

the increment size exceeds the remainder of the step and is decreased to 0.000000e+00

Adapter writing coupling data...
Adapter calling advance()...
--[precice] ERROR: advance() cannot be called with a timestep size of 0.

The problem seems to be that when transitioning to the second step, CalculiX sets the increment size to zero for one step. And preCICE can’t handle that.

So is it currently not intended to use multiple steps with the CalculiX adapter, or do I need a special configuration?


solid.inp (832 Bytes)
log.ccx (short) (26.7 KB)
precice-config.xml (2.4 KB)

Edit: I solved this using a single step and an *AMPLITUDE card. I had misunderstood the *AMPLITUDE method before, it does exactly what I want! :slight_smile:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.