OpenFOAM + CalculiX heat exchanger (CHT) tutorial does not run

System
Kubuntu 18.04LTS
preCICE v2.1
OpenFOAM v7
CalculiX v2.15


Background
I was trying to run a modified FSI flap tutorial and I ran into issues that I could not solve. So I decided to run the CHT tutorials. (I wanted to run FSI + CHT).

I checked the OpenFOAM+OpenFOAM CHT tutorial, it works fine.
I have checked the FSI flap tutorial for OpenFOAM+CalculiX, that works as well.
In conclusion, the adapter works fine with preCICE v2.1 (since I haven’t reinstalled the adapters.)

Issue
I am not sure what exactly is the issue, but it is coming from the Solid participant.
I followed the instructions and first downloaded the mesh files required and then ran the Allrun script.

Initializing coupling data
Adapter writing coupling data...
ASSERTION FAILED
  Location:          void precice::impl::SolverInterfaceImpl::writeBlockScalarData(int, int, const int*, const double*)
  File:              /home/prasad/Downloads/precice/src/precice/impl/SolverInterfaceImpl.cpp:1116
  Rank:              0
  Failed expression: valueIndices != nullptr
 0# getStacktrace[abi:cxx11]() in /usr/local/lib/libprecice.so.2
 1# precice::impl::SolverInterfaceImpl::writeBlockScalarData(int, int, int const*, double const*) in /usr/local/lib/libprecice.so.2
 2# precice::SolverInterface::writeBlockScalarData(int, int, int const*, double const*) in /usr/local/lib/libprecice.so.2
 3# precicec_writeBlockScalarData in /usr/local/lib/libprecice.so.2
 4# 0x00005649513937C5 in ccx_preCICE
 5# 0x0000564951394B5E in ccx_preCICE
 6# 0x000056495137E4C4 in ccx_preCICE
 7# 0x00005649511D2D0F in ccx_preCICE
 8# __libc_start_main in /lib/x86_64-linux-gnu/libc.so.6
 9# 0x00005649511DB07A in ccx_preCICE

I am attaching the log files for all three participants.Solid.log (5.0 KB) Inner-Fluid.log (5.6 KB) Outer-Fluid.log (5.6 KB)

The error message comes from preCICE and says that the vertex IDs (int*) handed over to writeBlockScalarData is a null pointer. So, sth is wrong in the CalculiX adapter or in the scenario setup concerning the meshes.

Do you use the v2.15 version of the CCX adapter? Did you modify the heat exchanger tutorial in any way?

Yes I am using the v2.15 version of calculix adaoter.

No I did not change anything in the tutorial.

@Alphaoo1 this seems to be exactly the same error as this one https://github.com/precice/calculix-adapter/issues/27

Interestingly, this should not be an issue anymore (even though it is still open). Could you please document your experience and dependencies there?

I was able to run the Heat-exchanger tutorial case with the new CalculiX adapter.
If I run the case with the adapter (with CCX v2.15) this issue persist.

As for the topic, the team may decide to keep it open or close.
Thank you for the help :smile:

Done.

@Alphaoo1 using the branch v2.15 or the branch v2.15_preCICE2.x? The fix should be in the latter, but not in the former one.

(for the future reader: “new adapter” here means for v2.16)

@MakisH It’s the v2.15_preCICE2.x

1 Like