CalculiX participant Mesh empty (OpenFOAM+CalculiX CHT)

System
I have Kubuntu 18.04 LTS
preCICE v2.1
I have not re-installed OpenFOAM and CalculiX adapters. They are what I had for preCICE v2.0.

What I am trying to do:
I am trying to run a 2-way coupling between OpenFOAM and CalculiX, but for heat transfer in of FSI.

For OpenFOAM, I took the Fluid folder from OpenFOAM (OF) adapter CHT tutorial.
I am also using the same precice-config.xml, with only one modification of changing participant name of Solid from Solid to CalculiX.(just for a bit better readability)

I then replaced the blockMeshDict with the one from flap_perp tutorial case.
And I did the necessary modification/adaptions to boundaryField of each file.

I ran this pure OF case, and it runs fines.

For CalculiX (CCX), I took the Solid folder from flap_perp tutorial case same as for Fluid participant.
I have modified the flap.inp to make a COUPLED TEMPERATURE-DISPLACEMENT simulation.
I ran this pure CalculiX case under gravity and some temperature at the fix1
, this runs fine as well. (But I remove the gravity for the coupled OF+CCX simulation).

I modified the confg.yml file to have Temperature and Heat-Flux instead of FSI keywords Forces and Displacements.

I am using the rumFluid script from OF+OF CHT tutorial, and I am using the runSolid script from flap_perp OF+CalculiX.

Issue:
The solid participant gives the following error:

---[precice] ERROR:  The provided mesh "Solid-Mesh" is empty. Please set the mesh using setMeshXXX() prior to calling initialize().

I tried the things I know but not sure what is causing this. :sweat_smile:
I am attaching the terminal output files as well.

Thank you for your support. :blush:

Log Files
Solid.log (3.8 KB) Fluid.log (5.2 KB)

The issue was with config.yml file.

Since I had modified the config.yml from FSI tutorial, there must have been some issue in indentation or an extra space at the end (not really sure).

This issue is a bit difficult to spot, since I was looking at the participant name, data keywords, mesh keywords etc., which matched exactly.

1 Like

@Alphaoo1 indeed, in YAML, indentation matters. Good that you spotted this yourself already!

It would be nice to have a CalculiX-native configuration format for the CalculiX adapter, but we are not working on this at the moment. Maybe in the future.

@MakisH Yes that would be nice, but anyways, there is other stuff on my priority list as well. :stuck_out_tongue:

Anyways, in the future, if somebody (including me) is stuck like this, they might get a hint from this topic.