Installation of preCICE on CRAY using Spack

  • preCICE version: 2.2.0
  • Operating system: CRAY XC-40
  • Installation method: Spack
spack install precice ^boost@1.74.0 %gcc@X.X.X

I am trying to install precice on CRAY using Spack and two packages are encountering errors while installing using Spack.


>> 135    libtool.m4: error: problem compiling CXX test program

>> 147    checking whether the C++ compiler supports templates for STL... configure: error: no


    './' '--prefix=/mnt/lustre/ase3/asesang/spack/opt/spack/cray-cnl7-sandybridge/gcc-10.1.0/boost-1.74.0-ni4xhokjmdexzxedvrqbecz2dnxzjqaf' '--with-toolset=gcc' '--with-libraries=regex,system,exception,iostreams,program_options,graph,filesystem,timer,serialization,log,atomic,random,wave,locale,thread,date_time,chrono,test,math' '--without-icu'

I thought the issue with berkeley-db was due to my gcc version. So I tried with both gcc10.1.0 and gcc6.1.0. The same error still persisted.

Kindly suggest what I could be doing wrong.


Did you follow the Spack guide on setting up Spack on Cray when configuring your Spack installation? There is some pitfalls/special options one has to take into account when using Spack on Cray.


Thank you for the suggestion. While I wasn’t able to install precice through spack, I was able to build it manually from source.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.