CalculiX adapter installation

Hi,
I’m trying to use the CalculiX adapter with preCICE 3.0.0. I am following the installation instructions and I have done the following:

  • put CalculiX in the home directory so that I have ~/CalculiX/ccx_2.20/src
  • retrieved the adapter wget https://github.com/precice/calculix-adapter/archive/refs/heads/master.tar.gz (it looks to me that the deb files looks for libprecice2…)
  • updated the Makefile CFLAGS with -fallow-argument-mismatch

Nevertheless I get the following compilation error:

 mpifort -Wall -O3 -fopenmp -I./ -I./adapter -I/home/claudio/CalculiX/ccx_2.20/src -I/usr/include/spooles/ -I/usr/local/include  -I/usr/include/  -c /home/claudio/CalculiX/ccx_2.20/src/cubtri.f -o bin/cubtri.o
 /home/claudio/CalculiX/ccx_2.20/src/cubtri.f:134:18:
 
134 |       CALL CUBRUL(F, VEC, W(1,1), IDATA, RDATA)
    |                  1
Error: Interface mismatch in dummy procedure ‘f’ at (1): 'f' is not a function
/home/claudio/CalculiX/ccx_2.20/src/cubtri.f:173:20:

173 |         CALL CUBRUL(F, VEC, W(1,J), IDATA, RDATA)
    |                    1
Error: Interface mismatch in dummy procedure ‘f’ at (1): 'f' is not a function
make: *** [Makefile:96: bin/cubtri.o] Error 1

Am I missing something? Thank you
Claudio

Hi @Claudio

Good catch that the deb files still look for libprecice2. I have made a change in the packaging recipe on a separate branch: GitHub - precice/calculix-adapter at use-libprecice3 Can you please try out this branch in a fresh procedure?

I have not seen the error before, so let us go step by step and figure it out.

Hi @IshaanDesai ,
I cannot reach the link you gave. I have tried with this tag calculix adapter v2.20.1 with a newly extracted CalculiX (version 2.20) source code, but I get the same error. I am using system libraries for spooles , arpack and yaml.
Can you please check the link above? I might have missed something.

Thank you
Claudio

Hi @Claudio

Sorry, the link was to a branch which was deleted. We have now added updates debian packages to the latest releases: Release v2.20.1 · precice/calculix-adapter · GitHub
Can you please try to install once more?

Hi @IshaanDesai
Thanks for the update. I have installed the .deb file that you linked and everything looks good. ccx_preCICE is found and no issues with preCICE v3 have appeared. Unfortunately I haven’t had the time to run the simulation I was planning, but I think this solves the installation problem.
claudio

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.