preCICE stops during "setting up primary communication to coupling partner"

Hi everyone,

I am new to preCICE. I have a similar problem as jianzhou722 had on Jul '22.
During the course I installed preCICE and tried the tutorials/quickstart/solid-cpp.
It compiled, after running ./ and the message defining mesh it hangs showing:
“setting up primary communication to coupling partner”

After downloading the Vagrant pricecevm I went directly to the same solid-cpp, compiled it and started it and got the exact same message.
Also tried the perpendicular-flap with same result.

Hi @Martin_Wilens,

I could imagine that this is related to some network detail. I am particularly wondering why this is failing in the Vagrant box.

Is this a macOS system? Is this a restrictive network?

See also:

as well as:

Hi @Makis,
I’m using a standard windows laptop and the problem exists at home as well as on the campus.
In the Vagrant box I can open FireFox and browse. In the terminal I can do a apt-get update so it looks like no network problem in the Vagrant box.

What does the other participant say?

:shushing_face: I made a biginners mistake. I didn’t start the second terminal yet because I thought I had to wait for a signal on the 1st terminal.
probably missed a few seconds in class :sleeping:
Thanks for the answers, I finished my first tutorial.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.