OpenFOAM adapter output during FSI simulation

I’m running a FSI simulation with OpenFOAM as fluid solver, using 8 processes. At the end of the computation each process outputs the coupling information (see the attached file: precice_log.txt (17.0 KB)). Is it correct or am I setting up something wrong? I guess that I used to grep the output and display only the “convergence” lines and I saw 2 lines per time-step, one for the forces and one for the displacements, even in parallel computation. I am using the adapter for OF v2012.
Thank you

Hi @Claudio,

you can tune a lot regarding the output you get: Logging configuration | preCICE - The Coupling Library

If this does not help, maybe upload your precice-config.xml and describe what exactly you want to see (compared with what you see now).

Hi @Makis,
thanks for your answer. I never realized that you can select the rank of the process which outputs the information. Just a curiosity, when is it useful to output coupling information from all ranks? In my case I always see the same data replicated.

This would mainly be interesting when used together with higher verbosity levels (debug and trace), mainly for debugging and development pursposes.

In the meantime, we use the following filter in our tutorials:

      filter="%Severity% > debug and %Rank% = 0"
      format="---[precice] %ColorizedSeverity% %Message%"
      enabled="true" />

But you are right, it should be suppressed by default, as discussed in Reduce default output of preCICE to master rank · Issue #579 · precice/precice · GitHub I think the issue is that overriding some of the settings clears the default. @fsimonis please confirm, maybe you have some idea how to improve this further.