Different dimensions for dimensions Issue

Hi all,

Recently I’m simulating an airfoil FSI case using OpenFOAM v7 / CalculiX v2.15 / preCICE v2.0.0.
Let’s begin with this snapshot:

This is what I have done:

  1. I firstly ran the OpenFOAM CFD simulation solely for 3 second of flow time to get a stable solution by removing the libpreciceAdapterFunctionObject.so from the system/controlDict.
  2. Then, I took this latest time step output as my initial input for the FSI case and I ran the FSI simulation.
  3. From the figure it can be seen that the error occurred at the 2nd iteration in the 1st coupling step.

My question is that whether this issue originated from OF side? I have checked all units in the OF and no mistakes are found.
Or, is this a potential issue during the preCICE coupling stage.

p.s. I used turbulence model in the OF side for the force predictions.

Any suggestions are very welcomed

Thanks in advance

A quick update:

Once I turned off the turbulence model in OpenFOAM, the simulation start the run successfully, without any error messages.

Perhaps this is related to the usage of the turbulence model?


Hi djmeee,

it looks like there is an issue with reading checkpoints (in the error trace I see the function readCheckpoint()). This seems to be an issue in the OpenFOAM adapter that we should fix, please open an issue describing your turbulence model settings.

In the meantime, you could try using explicit coupling (which will probably not be stable enough, at least not with large time step sizes).

Interestingly, the dimensions mismatch is m/s = 1/s. I wonder where exactly this comes from.

It would also be useful to build with debug symbols (add -g here, which we should actually add anyway).

Hi MakisH

Thanks for your comments.
Do you mean using:



Sure MakisH,

The issue has been reported and you can find it via this link:


1 Like

Hi everybody,

I have a new question, in my opinion, the precise only need force and displacement for data interpolations, doesn’t it?

The force is calculated by OpenFOAM where the momentum equations are solved, even if the turbulence model is turned on (e.g. k-omega SST is used), only the precision of the force will be affected but it has nothing to do data mapping, right?

Any ideas?

(please open a new thread for each new larger question, but fine here! :slight_smile: )

The OpenFOAM adapter cannot (or does not at the moment) directly access everything that is available inside OpenFOAM, mainly due to the function object approach (which offers several advantages). For this reason, we compute the force again. There are discussions for delegating such computations to OpenFOAM or to boundary conditions, but this would be a large redesign that we cannot prioritize at the moment. Additionally, it is not completely clear how it would affect compatibility with the different OpenFOAM versions.

Related issue for what you asked: FSI: Delegate the force calculation to the forces function object · Issue #143 · precice/openfoam-adapter · GitHub

Related PR and discussion for the redesign (at least for the CHT part): CHT: split code for preCICE adapter and openfoam by TEFEdotCC · Pull Request #150 · precice/openfoam-adapter · GitHub

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.