Communcation over sockets work for MPI-Fluid solver with 2 Procs, not for MPI-Fluid solver with 4 Procs

when I try to run my fluid solver (TRACE) in parallel mode and communication via sockets(precice compiled without mpi, master:sockets option in fluidsolver’s participant config set), I run into the following issue. When I run my fluid solver on 2 Procs, everything works fine, even if the speed up in computation time could maybe be better on my opinion, but nevermind.
The real problem is that the simulation is not working at all, if I try to run my fluid solver with 3 or 4 Procs, everything else exactly the same. After setting up the communication to the coupling partners and receiving a ‘Slaves are connected’ from both solvers, the fluid solver starts and waits at ‘Adapter reading coupling data’, what seems fine. On the other hand the Solid solver(CCX) stays at ‘Slaves are connected’ and nothing else happens.
I attach the precice-config.xml and terminal screenshots from the situation where both solvers are stuck.
Thank you for your help,

Solid terminal:

Fluid terminal:

precice-config.xml (2.9 KB)

Could be a problem in your TRACE adapter. Could it be that when you run with 2 procs, both procs are located at the coupling interface, but when you run with 3 or 4, there is now one proc that is not located at the coupling interface?

You need to call initialize and advance on all ranks, also on those that have no preCICE vertices.

If this does not help, you could build preCICE in Debug mode and switch on Debug logging. Then, we can see exactly where which rank is stuck.

You could use the first example here: Logging configuration | preCICE - The Coupling Library to not get too verbose output.

Thanks for your answer. As far as I can see, initialize and advance is called on all procs, even if I’m not 100% sure about this.

I attached the output from fluid an solid part with the suggested debug output active. Would be glad if someone can see if something or what is going wrong here.

fluidout.txt (8.6 KB)
solidout.txt (2.0 KB)

Your output does not contain debug logs (should be much longer). Did you (re-)build preCICE in Debug mode?

cmake -DCMAKE_BUILD_TYPE=Debug [...]

No, I did not rebuild preCICE with debug option yet. I will try to do so and get back to you.

1 Like