Can't run the FSI simulation(OpenFOAM for fluid, Solids4Foam for solid) by using preCICE with debug_mode


I run the case flexibleOversetCylinder following this toturial.
And my system is

  • Ubuntu 20.04LTS
  • OpenFOAM 2012
  • solids4Foam v2
  • preCICE 2.15

But this case doesn’t run as expected, the error is like that

And I got some questions,
1)when I run the FSI simulations by using same tools, except overset mesh, it works well. Or if I switch off the oscillation and deformation of solid part, this cashed FSI case with overset mesh works well. It seems that the issue is overset mesh, but then I run the checkMesh for the latest converged time step, the mesh quality is fine. please check the log file for the check mesh,

I feel confused now.
2) To get more information about the simulation, I plan to run this case using preCICE with debug mode, but I executed the operation following the official tutorial, I keep prefix as default, just run this command



sudp make install

and all tests passed, but when I ran the case, it couldn’t find the library of precice. Should I do more configuration?

Any suggestions are appreciate! Thank you!


Thanks! I solved this problem finally by specifying the custom prefix, and then add this into the .profile in Linux system.

1 Like

This sounds strange. Did you have any other preCICE version installed? I do not understand how the solution related to the problem.

Hi Makis,

Before compiling preCICE from the source, I just installed it via the .deb package. Yes, it’s weird, but I don’t know the reason yet.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.