CalculiX_MT and preCICE

Dear CalculiX / preCICE Users,

I’ve tried to compile the CalculiX version 2.20 with preCICE according the preCICE documentation on the www - but still get an error:

/usr/bin/ld: bin/ccx_2.20.a(dsptrf.o): undefined reference to symbol 'dlaev2_'
/usr/bin/ld: /lib/x86_64-linux-gnu/ error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status 

Exactly the same code compiles with makefile from CalculiX src (not the preCICE adapter) without any errors.
Also the code with installed on the system spooles and ARPACK (as in the precice documentation) compiles without errors.
I really don’t know where to look for possible solution, so kindly ask for your help and proposals.



Could you give us some further information?

Which distribution you are using, and what is its version?

Can you try if the original Calculix also compiles successfully using the Makefile_MT (make -f Makefile_MT)? The adapter compiles the MT version by default.


I do apologize for late answer but wanted to be sure, so double or triple-checked my compilation to avoid to many mistakes.
I have compiled the ccx2.20 for preCICE and as single solver (with ARPACK and SPOOLES).
For preCICE I have followed 1:1 the preCICE documentation on http preCICE page
For standalone application I have followed the ccx own documentation and Calculix — CoFEA Initiative.
Actually in both cases the difference starts at the Makefile: for standalone the only application I use the ccx Makefile and for preCICE the preCICE one.
The standalone compiles with no errors - I have runed the TEST files for MT=1, MT=2, MT=3 - via the compare script - there are some differences in the numeric values but think I have to live with it.
I’ve also repeated the process for ccx2.21 standalone compilation for MT usage - same as ccx2.20 - think it is OK.
But when I compile the ccx2.20 for preCICE using the dedicated preCICE Makefile (changing only the paths to the library’s) and using the same SPOOLES and ARPACK libraries as for standalone I get an error and the compilation will be aborted.