Boost version error using ubuntu 20.04

I installed precice2.1.1 using the latest binary package
‘libprecice2_2.1.1_bionic.deb’ using apt install on Ubuntu 20.04. I followed the instructions on your website for all prerequisits.

When I run the solverdummy I get:

/usr/bin/ld: Warnung:, benötigt von /usr/lib/x86_64-linux-gnu/, nicht gefunden (versuchen Sie mit using -rpath oder -rpath-link)

and lots of import error telling me precice requires libboost version 1.65. With Ubuntu 20.04 I have version 1.72. Is there any flag I have to set when installing the binaries to solve this issue?


The Ubuntu names are easy to mix up.
20.04 is Focal, 18.04 us Bionic. So, on 20.04, you need libprecice2_2.1.1_focal.deb.

That should explain the difference in Boost versions.

1 Like


that was indeed the problem. Now it works fine.

Thanks for your help!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.